正式入门深度学习,从顺利配置环境开始!其实之前接触ROS就知道,配置环境是新手最大的敌人。本文详细介绍了如何在Win10环境下去安装TensorFlow2的GPU版本。为了方便管理,我使用Anaconda进行虚拟环境的管理。这里我也不建议直接在电脑根环境配置,可能库版本会相互冲突。

TensFlow2.0安装环境要求:

  • Ubuntu 16.04或更高版本

  • Win7或更高版本(需要Visual C++)

  • macOs 10.12.6或更高版本,但不支持GPU

  • Python版本:3.6-3.9的64位版本

推荐使用MIniconda或者Anaconda来配置环境。

1、安装Anaconda

官网下载安装包,然后无脑安装就好了。点击Next,一切都按照默认值,可以改个安装路径,不要出现中文。

安装完Anaconda

然后在Anaconda Powershell Prompt (Anaconda3)中输入conda list命令,查看已经安装的库。安装成功的话,有numpy,qt,flask等各种各样的库。

查看以及安装的库

首先先来新建一个tensorflow虚拟工作环境(上来就放base环境里可不是什么好习惯( ̄▽ ̄)")。具体会在第三节进行讲解!

2、安装Visual C++库

这里的Visual C++不是VS2010那种软件,而是一个几MB的小库文件.可以直接在微软官网下载:

微软官网C++库下载地址

下载配套的C++库

下载下来之后,双击打开即可进行安装:

安装教程

安装完成之后需要重启一下电脑!!!

3、显卡的算力及驱动版本要求

在安装TF之前,需要了解一下显卡:

TensorFlow分为CPU版本和GPU版本,GPU版本可以利用英伟达GPU强大的计算加速能力,使TensorFlow的运行更为高效。如果没有显卡,那么就安装CPU版本。其实本质上没啥区别,只是训练速度比较慢。这里介绍GPU版本的安装。TensorFlow对NVIDIA显卡的支持比较完备,对于英伟达显卡,要求算力不低于3.5,一般较新的显卡都能满足条件。

可以在官网查看算力:https://developer.nvidia.com/cuda-gpus

常见的显卡算力

此外,除了对算力有要求,还需要了解一下驱动版本,一般要求驱动版本在450.80.02或者更高的版本!如何查看显卡的版本呢?直接在cmd命令窗里输入nvidia-sim就能看到!

驱动版本

4、安装TensorFlow的GPU版本

GPU版本的TensorFlow需要两个依赖库,分别为Cudatoolkit和Cudnn。使用conda安装的时候,不需要关心依赖库。

创建一个新的虚拟环境,我命名为TF,也就是tensorflow的简写。

创新一个新的虚拟环境

environment菜单,这里可以管理不同的虚拟开发环境,对环境中的科学包也都有可视化的管理,就像一个小仓库。base(root)虚拟环境是Anaconda的默认环境。点击create,并输入环境名称和python版本还有R版本(如果需要的话)。

python版本选择3.9即可。

Anaconda Prompt (Anaconda3)环境中,依次输入命令:

conda env list

conda activate TF

conda install tensorflow-gpu==2.6.0

最后输入y,选择进行安装即可

四步

进行安装:

安装

等待一段时间,完成安装。

5、测试是否安装成功

在安装的环境下(我的虚拟环境是TF),然后输入:

conda activate TF

python

import tensorflow as tf

然后发现有个警告,说numpy的版本太高了。 A NumPy version >=1.16.5 and <1.23.0 is required。检测到我的版本是1.23.1.

我猜想可能是我选择的python版本是3.9.

测试

这个问题也不大,直接在Aconda中对numpy进行降级就行:

降低Numpy版本

应用

然后再次检测是否安装成功,这一次是成功的,没有任何报错:

成功安装TensorFlow

6、查看tensorflow的版本号

查看版本号

7、依赖库安装

需要再安装一些其他的依赖库。和上面的命令差不多:

conda activate TF

pip install pandas matplotlib notebook keras==2.6.0

安装依赖库

安装之后,发现有出现了问题:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
tensorflow 2.6.0 requires clang~=5.0, which is not installed.
tensorflow 2.6.0 requires flatbuffers~=1.12, but you have flatbuffers 20210226132247 which is incompatible.

翻译一下:

错误:pip 的依赖解析器当前不考虑所有已安装的包。 此行为是以下依赖冲突的根源。
tensorflow 2.6.0需要clang~=5.0,没有安装。
tensorflow 2.6.0 需要 flatbuffers~=1.12,但是你有不兼容的 flatbuffers 20210226132247。

这两个问题也很好解决,就是版本库的版本问题。可以选卸载原来的版本,再安装要求的版本就好了!

pip uninstall clang

pip install clang==5.0

pip uninstall flatbuffers

pip install flatbuffers==1.12

解决问题


下载失败可以尝试切换国内源并用手机热点

如何切换到国内源呢?

查找切换源的地方

然后找到.condarc文件:

找到condarc文件

将里面的内容填写为:

channels:
  - defaults
show_channel_urls: true
channel_alias: https://mirrors.tuna.tsinghua.edu.cn/anaconda
default_channels:
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/r
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/pro
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/msys2
custom_channels:
  conda-forge: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud
  msys2: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud
  bioconda: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud
  menpo: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud
  pytorch: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud
  simpleitk: https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud

然后重启命令窗口。

重新开始第四步。



博主个人公众号
版权声明 ▶ 本网站名称:陶小桃Blog
▶ 本文链接:https://www.52txr.cn/2022/win10TensorFlow.html
▶ 本网站的文章部分内容可能来源于网络,仅供大家学习与参考,如有侵权,请联系站长进行核实删除。
▶ 转载本站文章需要遵守:商业转载请联系站长,非商业转载请注明出处!!

最后修改:2022 年 09 月 07 日
如果觉得我的文章对你有用,请随意赞赏